Umzug des Webservers, Probleme mit Datenbank

Manche haben’s vielleicht mitbekommen, es gab heute einige Aussetzer meines Blogs. Ich bin auf einen anderen Webserver umgezogen und hatte Probleme mit der Datenbank. Wie das oft so ist, machten die Umlaute Probleme. Beim Ausprobieren verschiedener Lösungsmethoden war dann teilweise die ganze Datenbank futsch und mein Blog war gar nicht mehr erreichbar. Es kam nur die Meldung „Error establishing a database connection“.

Wen’s interessiert: Ich hab die mySQL-Datenbank auf dem alten Webserver mit phpMyAdmin extrahiert und obwohl die Quelle den UTF8-Zeichensatz hatte und ich dies auch beim Import im phpMyAdmin des neuen Servers so angegeben habe, gab es lauter kaputte Umlaute. Interessanterweise aber nicht überall. Die Beiträge schienen in Ordnung, die Tags hingegen nicht. Die Kommentarvorschau in der Sidebar war fehlerhaft, die Kommentare unter dem Eintrag waren korrekt.

Ich hab dann den Tipp gelesen, trotz UTF-8 beim Import latin1 auszuwählen und nach 2-3 Versuchen hat das dann auch funktioniert.

Ansonsten sorry für die Aussetzer und sagt Bescheid, wenn euch was auffällt, was nicht geht.

4 Responses to “Umzug des Webservers, Probleme mit Datenbank”

  1. Da hier nichts kommt, teste ich jetzt mal selbst, ob Kommentieren noch geht. :-)

  2. Auf welchen Server bist du umgezogen, habe die gleichen Probleme gerade.

    LG Chris

  3. Zu Host Europe. Glaube aber nicht so wirklich, dass es am Provider liegt bzw. lag.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.